]> git.dujemihanovic.xyz Git - nixos-configuration.git/blobdiff - configs/server.nix
Separate config into server and laptop
[nixos-configuration.git] / configs / server.nix
similarity index 85%
rename from configuration.nix
rename to configs/server.nix
index b679930ecf5dbeb077b33ff1c221e0eb29edf2e1..672714844af080f28023d85b9103d4a10d8f327a 100644 (file)
@@ -1,26 +1,10 @@
 { config, pkgs, ... }:
 
 {
-  imports =
-    [
-      ./hardware-configuration.nix
-    ];
-
-  boot.loader.systemd-boot.enable = true;
-  boot.loader.efi.canTouchEfiVariables = true;
-
-  boot.extraModprobeConfig =
-    ''
-      options radeon si_support=0 cik_support=0
-      options amdgpu si_support=1 cik_support=1
-    '';
-
-  networking.hostName = "elitedesk"; # Define your hostname.
-  networking.interfaces.eno1.wakeOnLan.enable = true;
   systemd.network = {
     enable = true;
     networks."10-lan" = {
-      matchConfig.Name = "eno1";
+      matchConfig.Name = "*";
       DHCP = "yes";
       linkConfig.RequiredForOnline = "routable";
     };